Left hand pull

General Chat About Brakes, Wheels & Suspension

Moderators: phpBB2 - Administrators, Moderators

mfw898y
Junior
Junior
Posts: 115
Joined: Mon Jan 22, 2007 7:23 pm
Location: Rotherham
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Left hand pull

Post by mfw898y » Sat Jan 27, 2007 6:26 pm

Can anyone help. My 1.6 capri pulls to the left all the time and its worse under braking.
I've changed Steering rack, Track control arms, Track rod ends and wheel bearings and it drives like a different car but it still pulls :( it has relatively new calipers and the brakes aren't binding. The steering wheel also wobbles sometimes when it feels like it but i've had the wheels balanced twice. It doesn't look like it been in a smash. Any ideas :?:
Cheers in advance, Danny.



User avatar
Coops
Site Admin & Owner
Site Admin & Owner
Posts: 604
Joined: Sun Jan 21, 2007 7:59 pm
Location: Compton, Nr Newbury, Berkshire Drives: Supercharged 4.6 efi V8 Capri
Contact:

Post by Coops » Sat Jan 27, 2007 6:49 pm

i had a similar thing
and changed all the above,
turned out to be my cross member in the end, :roll:
Regards Tony C (COOPS)
Image
MS2 V3.57 Ecu mapable efi and wasted spark ignition.
Rotrex C38-91 supercharger and Cossie RS500 Intercooler @ 14psi of Boost.
Sponsored by: www.extraefi.co.uk & www.interpart.biz & www.caprisport.com
Web site: http://www.capriracing.co.uk

mfw898y
Junior
Junior
Posts: 115
Joined: Mon Jan 22, 2007 7:23 pm
Location: Rotherham
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Post by mfw898y » Sat Jan 27, 2007 7:43 pm

in what respect....bent?

User avatar
Coops
Site Admin & Owner
Site Admin & Owner
Posts: 604
Joined: Sun Jan 21, 2007 7:59 pm
Location: Compton, Nr Newbury, Berkshire Drives: Supercharged 4.6 efi V8 Capri
Contact:

Post by Coops » Sat Jan 27, 2007 8:06 pm

no mine was drilled wrong one end where the track arm bolts into,
Regards Tony C (COOPS)
Image
MS2 V3.57 Ecu mapable efi and wasted spark ignition.
Rotrex C38-91 supercharger and Cossie RS500 Intercooler @ 14psi of Boost.
Sponsored by: www.extraefi.co.uk & www.interpart.biz & www.caprisport.com
Web site: http://www.capriracing.co.uk

mfw898y
Junior
Junior
Posts: 115
Joined: Mon Jan 22, 2007 7:23 pm
Location: Rotherham
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Post by mfw898y » Sat Jan 27, 2007 8:11 pm

My god that sounds like a monster job. Am i right in thinking the whole world is connected to the crossmember. How did you find out? Do you just measure the holes from the ends?

spookie
Newbie
Posts: 42
Joined: Mon Jan 22, 2007 8:40 pm
Location: Cambs
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Post by spookie » Sat Jan 27, 2007 9:04 pm

Hi, one thing you have not mentioned is the shock absorber or the coil spring. Are these ok? Is the ride height the same both sides of the car, and is the damping the same.
Just another area to look at if you allready have not.

mfw898y
Junior
Junior
Posts: 115
Joined: Mon Jan 22, 2007 7:23 pm
Location: Rotherham
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Post by mfw898y » Sat Jan 27, 2007 9:10 pm

The back springs hang lower than a slappers knickers but the front seem equal with no excessive bounce. The springs are seated correctly as far as i can see.

gardener68
Newbie
Posts: 1
Joined: Wed Jan 24, 2007 11:37 pm
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Post by gardener68 » Sun Jan 28, 2007 12:00 am

try jacking it up an getting the front wheels of the ground.turn the wheels one side to the other to see if everything feels even lock to lock.
might be a strut top mount binding.
and try using handbrake to see if its got anything to do with rear brakes.

mfw898y
Junior
Junior
Posts: 115
Joined: Mon Jan 22, 2007 7:23 pm
Location: Rotherham
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Post by mfw898y » Sun Jan 28, 2007 6:53 pm

Cheers guys for all the advice! Front seems unrestricted. Pulled handbrake and it did pull left once and it always locks passenger side wheel. Just a thought but the rear antiroll bar looks bent. It is not symmetrical on both sides where it fastenes to body. Also it looks as if there is an adjustable eye. Is this used to line up the axle?

bortaf
Newbie
Posts: 16
Joined: Wed Jan 24, 2007 12:06 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Post by bortaf » Wed Jan 31, 2007 2:47 pm

Has the tracking been set? are the rear brakes adjusted correctly? if not all the braking will be on the front and road camber will pull the car to the curb?

mfw898y
Junior
Junior
Posts: 115
Joined: Mon Jan 22, 2007 7:23 pm
Location: Rotherham
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Post by mfw898y » Wed Jan 31, 2007 9:23 pm

Its had new cylinders on back less than 6 months ago and mechanic say track within 1 degree. Think I'm gonna have to get a 4 wheel track and check to see if owts bent :cry:
The tops of the springs didn't move with steering. They are fixed i.e winding up when turning left and right. I've heard two different oppinions on whether this is normal including mechanic. It seems wrong to me but then i'm not up to speed on suspension. Anyone know?

Capri2.8i
Newbie
Posts: 28
Joined: Sat Jan 27, 2007 11:29 am
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Post by Capri2.8i » Wed Jan 31, 2007 10:02 pm

U can try all u want m8.... but the real problem will end up being your right caliper not working correctly. Could be contaminated pads, brake hose expanding, piston sticking, air in the system, but unless u have a broken spring or shock on left, its ur brakes to blame.

John

mfw898y
Junior
Junior
Posts: 115
Joined: Mon Jan 22, 2007 7:23 pm
Location: Rotherham
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Post by mfw898y » Thu Feb 01, 2007 7:44 pm

You write with such conviction! Hope its that simple!

OLD SKOOL KID
Contributor
Contributor
Posts: 37
Joined: Sat Jan 27, 2007 9:20 pm
Location: 100 miles from smoke city
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Post by OLD SKOOL KID » Thu Feb 01, 2007 11:23 pm

Two other areas to check would be the front anti roll bar bushes as under breaking the inertia makes the roll bar move if the near-side bush is u/s that will cause the n/s wheel to move further back that the o/s this would also cause the steering wheel to wobble
The second thing to check is that both front tyres are the same make/size etc as different makes have slight difference in rolling radius
hope u get it sorted as I know it!s a s*** to cure.
Every capri I have ever owned suffered from some sort of steering wobble @ one time or another.
Never Drive Faster That Your Angal Can Fly......:-)

mfw898y
Junior
Junior
Posts: 115
Joined: Mon Jan 22, 2007 7:23 pm
Location: Rotherham
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable

Post by mfw898y » Fri Feb 02, 2007 5:14 pm

Cheers for the advice. I'm ordering polyflex bushes as I type. 8)

Post Reply
[phpBB Debug] PHP Warning: in file [ROOT]/vendor/twig/twig/lib/Twig/Extension/Core.php on line 1275: count(): Parameter must be an array or an object that implements Countable